24 lines
519 B
Nix
24 lines
519 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, flake-utils }:
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in {
|
|
devShell = pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
powershell
|
|
];
|
|
|
|
shellHook = ''
|
|
export DATABASE_URL=sqlite://db_dev.db
|
|
'';
|
|
};
|
|
}
|
|
);
|
|
}
|