FitLog/flake.nix
2025-04-09 22:29:45 +02:00

45 lines
1.1 KiB
Nix
Raw Permalink Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{
description = "SvelteKit Fitness Tracker - Nix Flake";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils, ... }:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs {
inherit system;
config = {
allowUnfree = true;
};
};
nodejs = pkgs.nodejs_23; # or your preferred Node version
yarn = pkgs.yarn; # or pkgs.nodePackages.pnpm if you prefer
nodePackages = pkgs.nodePackages;
in
{
devShells.default = pkgs.mkShell {
name = "sveltekit-dev-shell";
buildInputs = [
nodejs
yarn
pkgs.git
nodePackages.svelte-language-server # Added Svelte Language Server
];
shellHook = ''
echo "🚀 Welcome to the SvelteKit dev shell!"
echo "🛠 Node: $(node -v) | Yarn: $(yarn -v)"
echo " Svelte Language Server is ready!"
'';
};
}
);
}